Eroare: Nu a putut găsi preset „es2015” în raport cu directorul cu node js (Programare, Node.Js)

ashwintastic a intrebat.

nodejs version 8.9.0 && npm version 5.5.1. Vreau să folosesc es6 cu node js my package.json și .babelrc este mai jos orice idee!!! de ce primesc această eroare

{
  "name": "something",
  "version": "1.0.1",
  "description": "some text",
  "main": "server.js",
  "scripts": {
  "test": "echo 
Error: no test specified
 && exit 1",
  "start": "nodemon server.js --exec babel-node --preset es2015"
},
 "author": "xyz",
 "license": "MIT",
 "dependencies": {
  "babel-polyfill": "^6.26.0",
  "babel-preset-node6": "^11.0.0",
  "bcrypt": "^1.0.3",
  "body-parser": "^1.18.2",
  "express": "^4.16.2",
  "mongoose": "^4.12.6",
  "morgan": "^1.9.0"
 },
  "devDependencies": {
"babel-cli": "^6.26.0",
"babel-preset-es2015": "^6.24.1",
"nodemon": "^1.12.1",
"rimraf": "^2.6.2"
   }
 }

.babelrc fișier

  {
   "presets": ["es2015"]
}

Primesc această eroare când execut npm start

2 răspunsuri
lecstor

ați rulat npm install?

Am replicat mesajul cu package.json, .babelrc, și cu nodemon și babel-cli instalate global. îți recomand să dezinstalezi aceste module la nivel global, și orice alte module pe care le poți instala local în schimb, deoarece vor duce doar la confuzie.

De asemenea, vă recomand

"start": "babel-watch server.js"

și babel-preset-env în loc de babel-preset-es2015.

.babelrc

{
  "presets": [
    ["env", { "targets": { "node": "current" } }]
  ]
}

shivaay

Exemplul corect ar fi să folosiți numele pachetelor npm, de ex:

presets: ["babel-preset-es2015", "babel-preset-es2016", "babel-preset-es2017"].map(require.resolve)

Tags: