MIDP în Java ME SDK 8.1 (Programare, Sdk, Java Me, Midp)

0xF a intrebat.

Am un proiect CLDC 1.1 / MIDP 2.0 care a fost compilat bine cu Java ME SDK 3.2.

Recent, am actualizat Java SE la 8 și, ca urmare, Java ME SDK a început să afișeze erori la pornirea Windows (spunând că versiunea Java este 8 în timp ce se așteaptă 7).

Așa că am actualizat Java ME SDK la 8.1. Problema mea este că acesta nu conține midp_2.0.jar, așa că nu știu cum să-mi compilez proiectul. Compilatorul afișează erori de genul::

package javax.microedition.lcdui does not exist

Ce ar trebui să instalez pentru a-mi compila proiectul MIDP?

Comentarii

  • Oracle Java ME 8.1 este destinat doar utilizărilor încorporate și, prin urmare, nu vine cu o implementare a profilului MIDP (fără LCDUI). Cu toate acestea, oferă o implementare a profilului MEEP, care este o evoluție a IMP-NG. –  > Por Gabriel Cuvillier.
1 răspunsuri
0xF

Rezolvat prin instalarea Java ME SDK 3.4. Acesta este compatibil cu Java SE 8.