Pool-ul de aplicații se oprește automat atunci când navighează aplicația web în IIS7 (Sharepoint, Administrație Centrală, Iis)

Jignesh Rajput a intrebat.

Când navighez în Administrația centrală, primesc cereri de autentificare repetate și nu pot vizualiza pagina. Primesc următoarea eroare:

Service Unavailable (Serviciu indisponibil)

Eroare HTTP 503. Serviciul nu este disponibil.

Pool-ul de aplicații din IIS 7 este afișat ca fiind oprit. Toate aplicațiile web au această problemă.

Am căutat pe Google și am setat Credential în (Advance setting->Identity) pe Application Pool of Central Administration, dar cea de-a doua aplicație web a mea era în FBA Configuration, așa că atunci când navighez la ea primesc aceeași eroare ca mai sus.

Comentarii

  • Poate doriți să obțineți mai multe informații despre eroare prin verificarea jurnalelor. Încercați Ulsviewer archive.msdn.microsoft.com/ULSViewer –  > Por Jimbo Alba.
  • @Jigs – vă mulțumim pentru întrebare. Am încercat să o editez pentru a îmbunătăți gramatica, dar vă rog să o verificați pentru a vă asigura că am înțeles corect întrebarea dvs. inițială și să o modificați dacă este necesar. Mulțumesc. –  > Por SPDoctor.
  • Pe lângă jurnalele ULS, vă sugerez să verificați jurnalele de evenimente Windows pentru erori – este posibil să nu fi ajuns până la SharePoint. –  > Por SPDoctor.
12 răspunsuri
Andy Burns

Am descoperit că problema pe care am avut-o și care a dus la un 503 se datorează App Pool fiind setat să suporte aplicații pe 32 de biți.

Am mers la IIS manager, app pool, setări avansate și am setat „Enable 32-bit applications” la „False”.

Totuși, acest lucru a fost pe un Content App pool, nu pe Central Admin.

Comentarii

  • @sir – este deja setat False. dar Till nu este setat Fix Issue. –  > Por Jignesh Rajput.
Tanuja Chapa

Verificați dacă acreditările pentru domeniul dvs. s-au schimbat și nu le-ați aplicat.

Dacă aceasta este problema, modificați următoarele: – Deschideți app pool advance setting > Identity > custom account > Set (give user name and passowrd)

Comentarii

  • ar trebui niciodată setați acest lucru prin IIS. Folosiți Central Administration > Security > Service Accounts pentru a seta conturile pentru servicii! –  > Por Anders Rask.
Ashish Madkaikar

1) Deschideți IIS.

2) Faceți clic dreapta pe Application-Pool pentru aplicația web și selectați „Advanced Settings” (Setări avansate).

3) Setați „Rapid-Fail Protection” -> „Enabled” (Activat) la False (Fals).

Comentarii

  • M-aș gândi că răspunsurile nu sunt doar un manual de pași, ci mai degrabă un ghid care explică și de ce și nu doar cum. Puteți să vă îmbunătățiți răspunsul oferind indicii despre ce este „Rapid-Fail Protection” și de ce vă ajută dezactivarea acesteia. Oricum, o să caut, dar totuși observația mea este valabilă. Mulțumesc +1 –  > Por Mzn.
  • technet.microsoft.com/en-us/library/cc787273%28v=ws.10%29.aspx pentru informații despre protecția împotriva eșecurilor rapide –  > Por Mzn.
Deepu Nair

Verificați dacă contul care rulează serviciile de pool de aplicații (DomainUsername) este blocat în Active Directory. Dacă este blocat, pot apărea aceste probleme.

Trebuie să mergeți la IIS Manager și să intrați în secțiunea App pool. Verificați grupurile de aplicații care sunt oprite și verificați numele de utilizator (DomainUsername) utilizat.

Pentru a debloca, mergeți la Active Directory, căutați același utilizator, editați proprietățile și va exista o opțiune de bifare pentru a debloca contul.

Comentarii

  • Parola utilizatorului s-a schimbat și am avut probleme cu app pool-ul cam o lună mai târziu, când am repornit serverul. –  > Por Jerther.
Aben Samuel

Încercați să adăugați http://server_name:port_of_centralAdmin la Site-urile Intranetului local, închideți browserul și încercați din nou.

De asemenea, încercați să faceți acest lucru de pe serverul SP. Dacă da, ați dezactivat Loopback-ul?

De asemenea, verificați dacă contul dvs. de fermă de la Application Pool este A ok.

Salutări

David Lozzi

Verificați Event Viewer pe server? Înclin spre permisiuni/identitate a pool-ului de aplicații.

Comentarii

  • în Event Viewer am primit această eroare „Application pool ‘<Application site name>’ este dezactivat automat din cauza unei serii de eșecuri în procesul (procesele) care deservește (deservesc) acest pool de aplicații.” –  > Por Jignesh Rajput.
  • Whoa… reporniți? Acest lucru poate ajuta la ștergerea tuturor lucrurilor și la un nou început. Mai sunt și alte erori în jurul acesteia? –  > Por David Lozzi.
  • Da… a doua eroare este: Serviciul SharePoint 2010 Timer s-a încheiat în mod neașteptat. A făcut acest lucru de 38 de ori(e). Următoarea acțiune corectivă va fi luată în 30000 de milisecunde: Reporniți serviciul. –  > Por Jignesh Rajput.
  • Ați făcut o repornire? –  > Por David Lozzi.
  • nupe..am crezut că poate toate lucrurile se întorc când voi face upgrade serverul meu sharepoint 2010 (cu August CU 2010), dar încă nu-mi rezolvă problemele. așa că decideți să reporniți PC-ul 😛 && mulțumesc tuturor băieților pentru că m-au ghidat. –  > Por Jignesh Rajput.
CScott

Am văzut că acest lucru se întâmplă astăzi după ce serverul nostru SharePoint 2013 a fost actualizat cu cele mai recente actualizări Windows.

Am adăugat conturile de servicii care rulează grupurile de aplicații la politica de securitate locală „log on as a batch job” și am pornit grupurile de aplicații în IIS și asta părea să rezolve problema.

SharePoint 2013: Configurații și permisiuni ale conturilor de servicii

Lucas Izar

Am avut această problemă și când am căutat soluția în IIS, mi-am dat seama că doar acest AppPool avea contul de utilizator de identitate diferit. Așa că am schimbat Identity User Account, am pornit din nou Pool-ul și funcționează!

Sper că vă ajută!

lgaud

Tocmai am avut același simptom pe unele VM-uri din cauza „The trust relationship between this workstation and the primary domain failed” – soluția acolo este de a părăsi și apoi de a te reînscrie în domeniu. În acest caz, am reușit să mă conectez prin intermediul consolei VM, dar am primit eroarea de încredere prin intermediul desktop-ului la distanță.

http://support.microsoft.com/kb/162797

KayEye

Am încercat tot ce am găsit pe internet, dar de fiecare dată când deschideam administrația centrală se oprea app pool-ul. Rularea SharePoint Configuration Wizard a rezolvat totul pentru mine.

Lakshmi Murugavadivelu

În cazul meu Application Pool s-a oprit automat din cauza fișierelor de jurnal nu are spațiu.

Când am verificat jurnalele SharePoint am văzut eroarea ULS logs a atins limita maximă.

Apoi am șters fișierele jurnal din folderul

C:Program FilesCommon Filesmicrosoft sharedWeb Server Extensions15LOGS

Apoi toate site-urile au început să funcționeze.

Sandip Parmar
  1. Mergeți la IIS -> Application Pool
  2. În Setări avansate -> faceți clic pe Identitate sub Model de procesare
  3. Mergeți la Custom account -> setați usename password cu Domain name

Acum încercați să accesați site-ul web. Atunci funcționează pentru cazul meu.